CentOS 5 Official Support Closure

As previously advised in the ScopServ blogs and ScopNEWS, CentOS 5 has now officially reached its End Of Life date. As a result, CentOS has officially shutdown their official repositories for CentOS EL5.

centoscycle

From now, if you are updating your existing ScopTEL EL5 packages this may cause errors similar to the following:

[root@pstn ~]# scopserv_yum update

==== scopserv_yum ====

— Executing yum…

Loaded plugins: fastestmirror

Loading mirror speeds from cached hostfile

* centos-extras: mirror.netaddicted.ca

* centos-os: centos.mirror.iweb.ca

* centos-updates: centos.mirror.iweb.ca

* scopserv: us.mirrors.scopserv.com

http://mirror.netaddicted.ca/CentOS/5.11/extras/x86_64/repodata/repomd.xml: [Errno 14] HTTP Error 404: Not Found

Trying other mirror.

http://mirror2.evolution-host.com/centos/5.11/extras/x86_64/repodata/repomd.xml: [Errno 14] HTTP Error 404: Not Found

Trying other mirror.

http://centos.mirror.ca.planethoster.net/5.11/extras/x86_64/repodata/repomd.xml: [Errno 14] HTTP Error 404: Not Found

Trying other mirror.

http://centos.bhs.mirrors.ovh.net/ftp.centos.org/5.11/extras/x86_64/repodata/repomd.xml: [Errno 14] HTTP Error 404: Not Found

Trying other mirror.

http://centos.westmancom.com/5.11/extras/x86_64/repodata/repomd.xml: [Errno 14] HTTP Error 404: Not Found

Trying other mirror.

centos-extras                                                                                     | 2.1 kB     00:00

 

This does not mean your installation is broken, it simply means that the official CentOS EL5 mirrors have been shut down. ScopServ has released a new scopserv-server package that uses vault.centos.org to maintain existing dependencies.  This package will be automatically installed via scopserv_yum update and if the scopserv-server package is updated you will not see this error the next time you do scopserv_yum update.

Here are the options to resolve the error (pick one):

  1. Update your packages using the ScopTEL GUI
  2. From a bash prompt execute ‘scopserv_yum update’ (omitting quotes)
  3. ‘rpm –Uvh http://download.scopserv.com/dist/packages/scopserv-server/scopserv-server-5.1.6.11.20170601-1.nodist.scopserv.noarch.rpm’ (omitting quotes)

Since CentOS 5 is officially End Of Life ScopServ highly recommends that you upgrade your installation to CentOS 6.

A failure to do so will put your installation at risk since CentOS EL5 is no longer supported.

Please follow the official instructions to upgrade your installation at

https://blog.scopserv.com/2016/12/scoptel-centos-6-x-bootdisk-installation-guide/

ScopServ will not be responsible for any liabilities caused by a failure to upgrade to a supported Operating System.  Additionally, ScopServ will be announcing an End Of Life date for ScopServ EL5 packages and support in the near future.